---
title: Syslog Server
slug: litmusedge/syslog-server
docTags: 
createdAt: 2024-06-20T17:28:26.882Z
---

Review the following information for setting up and configuring the Syslog Server&#x20;driver.&#x20;

See [Syslog Server Reference](docId\:UUNIXbNTMTjrqb7INQ4ob) for more information.&#x20;

# Litmus Edge Compatible Series

| Compatibility parameter      | Compatible items                                                      |
| ---------------------------- | --------------------------------------------------------------------- |
| **Driver type**              | Ethernet                                                              |
| **Validated devices/series** | [Hirschmann Greyhound](https://www.belden.com/products/greyhound1040) |

# Configure Syslog Server

Configure the following parameters. Update the default values to your specific setup.&#x20;

| Parameter        | Value                                           |
| ---------------- | ----------------------------------------------- |
| **Type**         | Network Utility                                 |
| **Driver**       | Syslog Server                                   |
| **Log Protocol** | Select BSD Syslog (RFC3164) or Syslog (RFC5424) |

Configure the remaining settings as needed if they are enabled.

## UDP Settings

:::hint{type="info"}
**Note:&#x20;**&#x49;f you choose UDP mode, the device will begin listening on the interface you specified. Its status will be *DISCONNECTED&#x20;*&#x75;ntil it receives a valid syslog message from any client. You can modify how long the device remains *CONNECTED* after receiving a message by adjusting the *UDP Timeout&#x20;*&#x73;etting.
:::

| Parameter         | Value      |
| ----------------- | ---------- |
| **UDP Interface** | 0.0.0.0    |
| **UDP Port**      | 514        |
| **UDP Max PDU**   | 4096       |
| **UDP Timeout**   | 30 seconds |

## TCP Settings

| Parameter         | Value                                                                                                                       |
| ----------------- | --------------------------------------------------------------------------------------------------------------------------- |
| **TCP Interface** | 0.0.0.0                                                                                                                     |
| **TCP Port**      | 6514                                                                                                                        |
| **TCP Parsing**   | Select one of the following:<br />* Non-Transparent Framing (RFC6587)
* Octet Counting (RFC5425)
* Single Message (RFC5426) |

## TLS Settings

| Parameter                      | Value                                                                                                         |
| ------------------------------ | ------------------------------------------------------------------------------------------------------------- |
| **UDP Interface**              | 0.0.0.0                                                                                                       |
| **UDP Port**                   | 6514                                                                                                          |
| **TLS Parsing**                | Select one of:<br />* Non-Transparent Framing (RFC6587)
* Octet Counting (RFC5425)
* Single Message (RFC5426) |
| **Server Certificate**         | Update or copy as needed                                                                                      |
| **Server Private Key**         | Update or copy as needed                                                                                      |
| **Min TLS Version**            | Select one of:<br />* TLS 1.0
* TLS 1.1
* TLS 1.2
* TLS 1.3                                                   |
| **Require Client Certificate** | If enabled, upload the certificate.                                                                           |

## Advanced Settings

| Parameter                | Value              |
| ------------------------ | ------------------ |
| **Allow Multi Match**    | Enable or Disable  |
| **Stringify In Fields**  | Enable or Disable  |
| **Replace Empty Fields** | Complete as needed |
| **Minimum Clients**      | 1                  |
| **Max Workers**          | 1                  |

:::hint{type="info"}
**Note**: The *Minimum Clients* setting is not applicable when UDP is enabled. If UDP is enabled, do not change this setting.&#x20;
:::

# Configure the List of Registers

When you [Add Tags](docId\:XgWOkQbTPevII7OR82LL0) to the Syslog Server, refer to the following register table and tag parameters.&#x20;

## Register Table

| **Name**                  | **Value Type** | **Access Type** |
| ------------------------- | -------------- | --------------- |
| Match (String Publish)    | string         | R/W             |
| Match (JSON Publish)      | json           | R/W             |
| Ignore Match (No Publish) | null           | R/W             |

## Tag Parameters

- **Name**: Select a register name from the drop-down list. The available options depend on the names in the register table.&#x20;
- **Value Type**: Select a data type from the drop-down list. The available options depend on the register name selected.&#x20;
- **Tag Name**: Enter a name for the tag.
- **Description** (Optional): Enter a description for the tag. &#x20;
- **Severity**: Select the severity limit.&#x20;
- **Facility**: Select the facility.&#x20;
- **Wildcard**: Select the wildcard character. &#x20;
- **Hostname**: Configure the hostname (String Match).&#x20;
- **Appname**: Configure the appname (String Match).&#x20;
- **Msg ID**: Configure the MessageID (String Match).&#x20;
- **Message**: Configure the Message (String Match).&#x20;
- **Structured Data**: Configure the Structured Data (Field Match).&#x20;
- **Client Address**: Configure the Client CIDR Address (Address Match).&#x20;
- **Order**: Enter a value for match process ordering.&#x20;
- **Format**: Configure the JSON Publish Format. This is not available if you select the Name *Ignore Match (No Publish)*.&#x20;

